Tag Archives: EFI

Vaio Pro 13 Fedora

Sony Vaio Pro 13 vs Fedora 19

So I gave in and purchased my shiny new i5 Vaio Pro on Saturday from JB HiFi for $1184 with a bonus 1TB Sony 2.5″ USB3 HDD thrown in for free.

The first order of business is of course removing Windows đŸ˜‰

Well it was more of a fight than I thought it would be (or maybe, due to the fact I usually install Linux on older laptops which tend to have better support, I was just naive).

After waiting what seemed like an age to burn the Windows 8 Recovery DVDs (all 4 of them, taking a grand total of about 2 hours on my slow USB DVD burner) it was time to remove Windows 8.

Removing Windows was painless, insert the Fedora 19 DVD and power on the Vaio using the ‘ASSIST’ button positioned above the keyboard. After disabling Secure Boot and booting the Fedora Installer, the installation proceeded without incident.

Upon rebooting however, I was greeted with a screen stating that the Vaio could not start Windows. After much googling it seemed the issue lies in the non-compliant Insyde H20 BIOS looking for the EFI bootloader in only certain locations (/EFI/Microsoft, /EFI/redhat, /EFI/Boot) and requiring it to have a certain filename. This is a problem as Fedora by default adds its booloader to /EFI/fedora/grubx64.efi.

The solution is to copy the ‘fedora’ directory to one called ‘Boot’ (so you end up with /EFI/Boot). The file grubx64.efi must then be renamed to bootx64.efi. This will require a LiveCD or the Rescue mode on the install DVD. This allowed the system to boot. Update: If you experience difficulties booting, copying the files or random error messages are printed to the screen, read this.

A quick check revealed  most hardware working correctly including the touchscreen, keyboard backlight, USB, Audio, Touchpad (with a few minor annoyances that I have yet to fix). The exception to this is of course is WiFi. (From my investigation it seems the Ubuntu kernel is compiled with support for this adapter so it *may* work out of the box or simply require the firmware instead of a full kernel compile)

The Vaio Pro 13 uses an Intel 7260 802.11ac wireless adpater which currently has some issues in Fedora. This first issue is that the iwlwifi module in the the current shipping Fedora kernel (3.9.8) does not even detect the card as it lacks the PCI ID for the Sony derivative. So to fix this I downloaded the SRPM for the kernel and added my 1 line patch to add the PCI ID.

After compiling and installing the new kernel, the GRUB2 conf file must be updated as it is now in a non-standard location. Run the following command as root:

# grub2-mkconfig -o /boot/efi/EFI/Boot/grub.cfg

Now reboot and then run dmesg, which should show that the device is detected and now requires firmware (iwlwifi-7260-6.ucode).

The second issue is that the firmware is not currently shipped by Fedora. Luckily I found an rpm here. Then its just a matter of running #modprobe -r iwlwifi and  #modprobe iwlwifi or rebooting.

dmesg now showed a segfault in iwlwifi. Determined to get WiFi working I went to koji and found the latest kernel build (3.10.0-0.rc7) and proceeded to patch and test it. This time it was successful, the firmware was loaded and NetworkManager connected to my WiFi network. The kernel rpms are avialable from here.

Another problem I have noticed but not yet fixed is the CPU frequency scaling. Using the ondemand governor the frequency is stuck at 800MHz. Changing to performance clocks it to 1.6Ghz but does not allow it to enter Turbo Mode. I will be investigating the new Intel PState driver in the future. UPDATE: I have applied a patch to enable the pstate driver in my new 3.10 Kernel. See this post for more details.

Overall it now works quite well and is a very capable Ultrabook. Let me know in the comments if you need any additional details about running Linux on it.